Sending Data to ioGAS

This feature is only available as part of the Geochemistry module. See Geochemical Data for more information.

This topic describes sending data to ioGAS and return it to Leapfrog Geo. Topics are:

ioGAS version 6.1 and later recognise holeid, From and To columns sent from Leapfrog Geo. Earlier versions of ioGAS can only import point data.

Creating a New ioGAS Data Object

To send data to ioGAS, you must first create a data object from the drillhole data in the project. This process uses data from a single interval table to create a new ioGAS object that can then be opened in ioGAS.

Note that interpretation tables cannot be used to send data to ioGAS. If you wish to send an interpretation table to ioGAS, export it from Leapfrog Geo and then import it back into the project.

There are two considerations when creating an ioGAS data object:

  • Are all data columns you wish to send over the ioGAS link in the same table? Creating an ioGAS data object uses a single interval table. If the data you wish to send is in different tables, create a merged table.
  • Are lithology intervals similar in length to assay data intervals or are there significant differences? The solution is to apply a majority composite to the lithology data using the interval lengths from the assay table and then create a merged table containing all the data columns you wish to send over the link.

See Merged Drillhole Data Tables and Majority Composites for more information.

To create a new ioGAS data object, right-click on the ioGAS object and select New ioGAS Data:

You can filter the data you send to ioGAS using any of the query filters defined in the project. Make sure the query filter you wish to use has been defined before you start creating a new data column.

In the window that appears, select the table you wish to use for the Base table, then select the columns to send to ioGAS. If you wish to filter the data, select the query filter required from the dropdown list.

Enter a Name for the data column and click OK. The new data column will appear as part of the ioGAS folder:

Note that any filter applied to the data is part of the new data object and will be sent to ioGAS over the link.

The next step is to open the data in ioGAS.

Opening the Data in ioGAS

Ensure that Leapfrog Geo is connected to ioGAS.

In ioGAS, select File > Open Link Data. Once the column has been opened, you can use the tools available in ioGAS to analyse the data. That the data is open in ioGAS is indicated in the project tree:

If you have the data visible in the Leapfrog Geo scene, changes made will be displayed in Leapfrog Geo. Here the ioGAS attribute manager has been used to assign colours to the selected values in ten equal ranges:

The changes to attributes are automatically updated in the Leapfrog Geo scene window as long as the link is live.

Sending a New Data Column Back to Leapfrog Geo

To save the changes and send a new data column back to Leapfrog Geo while the ioGAS link is live, select one of the Make Variable From options from the Data menu in ioGAS.

In Leapfrog Geo, the column will be added to the base interval table used to create the new lithology. Here, a column called MRV_Au has been added to the base table:

When the connection to ioGAS is terminated, the ioGAS data column will remain in the project tree as part of the ioGAS folder. Data columns created in ioGAS will also be available and will appear in the base interval table.