Editing Surfaces with Structural Data

In Leapfrog Geo, many surfaces can be edited using structural data points drawn in the scene. Surfaces that can be edited in this way include contact surfaces, model extents and interpolated editable meshes. There are two ways to do this:

  • If you have a structural data table created in or imported into Leapfrog Geo that you want to use to adjust the surface, right-click on the surface in the project tree and select Add > Structural Data. You will be prompted to select from the structural data tables available in the project.
  • If you want to create structural data points to use to adjust the surface, right-click on the surface in the project tree and select Edit > With Structural Data.

To edit a surface with structural data using the second option, it is a good idea to first add the object you wish to edit to the scene. Next, right-click on the surface in the project tree and select the Edit > With Structural Data option.

The structural data toolbar will appear and a new structural data object will be added to the scene. Draw the structural data points and adjust them as described in New Structural Data Tables, then click the Save button () to view the effect on the surface. Structural data tables created in this way cannot be used by other objects in the project until the table has been shared. To do this, right-click on the table in the project tree and select Share. The structural data table will be saved to the Structural Data folder.

To remove the structural data from the surface, expand the surface in the project tree. Right-click on the structural data object and select Remove.